GB might be an option if your buddy's old Mac can handle the update required to run the more recent versions with the drummer (GB 8 or 9, I think or else I'm confusing that with Logic).

Just how old is the old Mac? I've got a 2011 MBP and a 2013 iMac. Both are running GarageBand and Logic Pro X and can handle the more modern drum VSTs. Specifcally, EZDrummer, Addictive Drums and Steven Slate Drums.