The Fender Forum


LilyPix
Les Paul Forum
Cafe Wah

TFF Merchandise
TFF Homesite

Go Back   The Fender Forum > . > Amplifiers
Register FAQ Mark Forums Read Calendar Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-29-2008, 09:27 AM   #1
guitarjk
Forum Member
 
guitarjk's Avatar
 
Join Date: Mar 2008
Posts: 15
Hot Rod Deluxe/Deville Faceplate/Chassis

Has anyone found a fix for the (in my opinnion) sorry lettering on the faceplate on the Hot Rod Deluxe/ Deville amps. I have tried to find a chassis but Fender won't reply to emails. I have tried local repair shops which want to repair amps instead of help someone with parts. Is there anyone that makes an replacement knows of a fix for this problem?

THANKS
Jimmy
guitarjk is offline   Reply With Quote
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -7. The time now is 11:33 PM.




 
     
 
 


 

The Fender Forum is a privately owned and operated site.
The Fender Forum is in no way affiliated with Fender Musical Instrument Corporation.
All trademarks are the property of FMIC.

All messages on this forum express the views of the author
and do not necessarily reflect the opinions of
The Fender Forum and/or it's administration.
The Fender Forum will not be held responsible for the content
of any messages posted on this forum.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2002 - 2012 The Fender Forum